factuur in Excel

Factuur in Excel.

Op deze pagina vindt U een aantal voorbeelden van facturen die ik in de loop der jaren heb gemaakt van van een simpel eenvoudig formulier in gericht als factuur met bedrijfslogo welke U geheel handmatig moet invullen. Tot een volledig automatische factuur die door een boekingsnummer geheel automatisch wordt ingevuld compleet met klantgegevens. Steeds probeer ik met tekst een uitleg te vertellen hoe ik een en ander heb gemaakt.

Deze pagina is in voorbereiding start datum 1-1-17

1e voorbeeld

Factuur gekoppeld aan mutatieblad en klantenbestand

Voor dit voorbeeld heb ik gebruik gemaakt het rekenmodel Voorraadbeheer Trika 2014. Onderstaand het Mutatieblad waar U de inkopen en de verkopen vermeld. Dit blad is gekoppeld aan het hoofdbestand. Door het invullen van het artikelnummer worden alle bijbehorende gegevens in het hoofdbestand opgezocht. In de formulebalk ziet U een voorbeeld van de gebruikte formule. Op dezelfde manier wordt ook de klantnaam opgezocht. Let op het klantnummer

Klantenbestand:

De factuur:

Het eerste artikelnummer 301 in kolom E zorgt er voor dat het klantnummer in cel D5.  In de formule balk ziet U de formule. De formule zegt eigenlijk: Als in cel 14 niets staat, moet er niets gebeuren. Anders moet de inhoud van cel E14 opgezocht worden in het mutatieblad tussen cel/kolom C4 t/m S1641 de waarde uit de 10 kolom moet worden gevonden.

Met een zelfde soort formule wordt de inhoud van D5 gezocht worden voor naam Adres Postcode en Woonplaats

 

Voorbeelden gebruikte formule voor het invullen van de factuur:

Aantal: .=ALS($E14=””;””;VERT.ZOEKEN($E14;MUTATIES!$C$4:$S$1641;8;ONWAAR))  Kolom J de 8e kolom

Omschrijving: .=ALS($E14=””;””;VERT.ZOEKEN($E14;MUTATIES!$C$4:$S$1641;6;ONWAAR)) Kolom H de 6e kolom

 

2e voorbeeld

Factuur met ingebouwd calculatieschema met kortingsstaffel

automatische factuur: door het invullen van het boekingsnummer 201612001 (in dit voorbeeld) worden alle gegevens boven de streep automatisch ingevuld. Waar U FACTUUR en VERHUUR ziet staan zijn de cellen ingericht met keuzelijstjes. Bij FACTUUR kunt U kiezen uit Contant factuur en Credit Factuur.  Bij verhuur kunt U ook kiezen uit pakbon magazijn bon. Keuzelijstjes maak je met validatie (uitleg vindt U op deze pagina)

Alleen in de vakjes met het stippellijntje kunt U wat invullen, alle andere gegevens worden automatisch ingevuld. Zodra u onder de streep het nummer invult wordt van de boekingslijst het debiteurennummer via verticaal zoeken opgezocht. Op de boekingslijst worden nog meer gegevens vermeld zoals bv de interne code welke wordt gebruikt om een met de klant afgesproken korting te berekenen deze kan per artikelgroep verschillende zijn

 

 

De inhoud van het keuzelijstje kunt U buiten de print aanpassen met eigen tekst

 

 

Onder de streep worden dmv verticaal zoeken de verhuur periode en de huurprijs automatisch ingevuld en de eind totalen uitgerekend

kortingstabel.

Per klant wordt een korting afgesproken, deze kan per artikelgroep maar ook per klant verschillen. de kortingscode ziet U in de eerste kolom. Deze kortingcode wordt ook per relatie in het relatie bestand vermeld. op de factuur vindt U boven rechts de omschrijving interne code. Als de code 0 is (oa contante verkoop) wordt door voorwaardelijke opmaak op de factuur alle omschrijvingen van de kortingen voorzien van witte tekst zodat deze tekst voor klanten die geen korting krijgen onzichtbaar is

korting zoektabel:

In een verborgen gedeelte onder de factuur wordt de interne code in dit voorbeeld 20 onderaan vermeld d.m.v. cel verwijzing naar rechtsboven vervolgens worden d.m.v. horizontaal zoeken de bijbehorende kortingspercentages opgezocht   formule in de cel waar 10% staat onder de 1 =ALS($B108=””;””;VERT.ZOEKEN($B108;kortingstabel!$B$5:$Z$20;2;ONWAAR)) dit is een verwijzing naar de kortingstabel hierboven.

kortings calculatie

Kortingscalculatie wordt uitgevoerd in een verborgen gedeelte recht van de factuur. Bovenstaande factuur is ingericht voor 7 verschillende verhuur producten en 9 verschillende regels voor verkoop. bv Huur elektrisch gereedschap. de bijbehorende beitels moet U kopen. Per regel is de korting code klant gelijk maar per artikelgroep kan er een verschil zijn. De kortingen komen in een totaal bedrag op de factuur terecht

 

in kolom kortingscode staat deze formule =$J$15 dit is een verwijzing naar de cel waar de interne code in staat (20) boven in rechts op de factuur. Waar code 2 staat vindt je een verwijzing naar het hoofdbestand. .=ALS($B75=””;””;VERT.ZOEKEN($B75;Hoofdbestand!$B$6:$Q$1478;5;ONWAAR))  $B75 is het artikelnummer  met dit nummer moet de bijbehorende kortings-groepnummer worden opgezocht in kolom 5. de uitkomst is 2. Vervolgens wordt met horizontaal zoeken het bijbehorende kortingspercentage in een verborgen deel onder de factuur opgezocht: =ALS($R75=””;””;HORIZ.ZOEKEN($R75;$D$107:$AB$108;2;ONWAAR)) $R75 is de cel R 75 (regel 75 kolom R op het plaatje de eerste cel waar 2 in staat. D107-AB108 is het verborgen deel onder de factuur

——————————————————————————-

Bastion schoonmakers van huis uit.

Een voorbeeld van een simpel rekenmodel werkzaamheden met daaraan gekoppelde factuur.

Dit rekenmodel bestaat uit een database met allerlei werkzaamheden en materialen met vermelding van rekeneenheden, btw percentages en bijbehorende prijzen. Ook is er een database gemaakt waarin alle klanten worden vermeld. Deze 2 data bestanden worden gekoppeld aan een werklijst waar alle werkzaamheden in worden genoteerd.

database werkzaamheden en materialen

Database klantenbestand

Werklijst:

Iedere complete order krijgt een opvolgende boekingsnummer. Alle bijkomende items krijgen hetzelfde volgnummer gevolgd met een letter. Om de omschrijving in te vullen gebruikt U het nummer uit de database werkzaamheden en materialen, alle blauwe kolommen worden automatisch ingevuld dmv verticaal zoeken (hoe doe je dat) vervolgens vult U het klantnummer in. Het volgende boekingsnummer op onderstaande lijst zou 20170002 worden.

Factuur boven zijde:

Kolom A staat buiten het printgedeelte. Zodra U het boekingsnummer 20170001 invult wordt de eerste regel raamwassing buiten met behulp van verticaal zoeken vanaf de werklijst compleet ingevuld. tevens worden de klantgegevens automatisch ingevuld. Factuurnummer is boekingsnummer. Datum factuur formule =(NU). Vervolgens dient U nog de bijbehorende nummers in te vullen.

 

Onderzijde van de factuur:

voor uitleg btw berekeningen 21% en 6% zie uitleg bij het volgende plaatje

Uitleg btw berekeningen:

Buiten het printgedeelte op de zelfde hoogte als de factuur regels wordt in kolom M en N met behulp van de getoonde formule gekeken of er een H of een L in kolom G staat, vervolgens wordt het bedrag in kolom M of N geplaatst. In het gele vakje onderaan de factuur ziet U de optelling van kolom M regels 19 t/m 30

 

Als U vervolgens van deze factuur een sjabloon maakt, kunt U de originele factuur als reserve bestand in dit rekenmodel verbergen. U hoeft in Uw Excel programma maar op nieuw te klikken om een complete lege factuur aan te maken. Hoe maak je nu een sjabloon, het lijkt moeilijker als dat het is op mijn pagina steigerverhuur vindt U onderaan een complete uitleg met plaatjes

Geen tijd/zin om een rekenmodel als boven omschreven te maken, dit rekenmodel U ook bestellen de kosten zijn 14,50 euro bestelcode bastion 2017-001 info of bestel mail

 

Niet gevonden wat U zocht:

x